Back to overview
Resolved

Object Storage Incident

Jul 2, 2026 at 12:12am UTC
Affected services
REST API
Webhook Delivery via [clever.par.1]
Webhook Delivery via [clever.par.2]
Webhook Delivery via [scw.ams.1]

Resolved
Jul 2, 2026 at 10:50am UTC

Everything has been working correctly since last update. System is back to its nominal state. We will continue monitoring until incident is officially closed upstream.

Updated
Jul 2, 2026 at 10:16am UTC

Issue seems fixed upstream. We are gradually re-enabling object storage in API and workers, while monitoring the situation. Webhook delivery is still stable.

Updated
Jul 2, 2026 at 9:52am UTC

Fix was deployed on PG-based workers a few minutes ago: webhook delivery has recovered and queue is now empty.

Updated
Jul 2, 2026 at 8:27am UTC

Our PG-based workers are having issues delivering webhooks. Issue was identified and a fix is being written. Pulsar-based workers are not affected.

Updated
Jul 2, 2026 at 7:08am UTC

Our provider acknowledged the issue: https://www.clevercloudstatus.com/incidents/1086

Updated
Jul 2, 2026 at 4:50am UTC

We temporarily disabled writing incoming events to object storage; they will be written to database instead. This should improve event ingestion.

Created
Jul 2, 2026 at 12:12am UTC

We are seing transient issues with our object storage. Object storage is used to store incoming event payloads and responses to outgoing webhooks. Webhook delivery is still working, but in a degraded state.